Jump to content


Check out our Community Blogs

Register and join over 40,000 other developers!


Recent Status Updates

View All Updates

Photo
- - - - -

error in osCommerce admin page

oscommerce php server

This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1 Meghan

Meghan

    CC Lurker

  • Just Joined
  • Pip
  • 2 posts

Posted 22 May 2015 - 12:44 AM

I am running an osCommerce app on Hostforlife.eu. I'm not a php expert though. I recently found that some admin pages give errors. I narrowed the problem down to the following line:

$pIDlist_array=split("&", $_SERVER["argv"][0]);
$_SERVER["argv"][0] returns always NULL.

I think it's because "register_argc_argv" is off in global php configuration. 
I created php.ini in the web root directory and the file has register_argc_argv = on. But it doesn't seem to override the default option. So here are my questions:

- Can I override "register_argc_arg" in my php.ini on Hostforlife.eu? Do you have experience with them?

- If I can't change "register_argc_argv" option, what can I do?
- I want to avoid modify all source codes. But if that's the only option, how should I change the problem line?

I need your help, thanks in advance smilies_smile.png



#2 WingedPanther73

WingedPanther73

    A spammer's worst nightmare

  • Moderator
  • 17757 posts

Posted 22 May 2015 - 04:26 AM

We're probably going to see more code than that. Also what environment is this being run under? argv is only populated if run as a command-line script, for example.


Programming is a branch of mathematics.
My CodeCall Blog | My Personal Blog

My MineCraft server site: http://banishedwings.enjin.com/





Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download