Jump to content


Check out our Community Blogs

Register and join over 40,000 other developers!


Recent Status Updates

View All Updates

Photo
- - - - -

How to install gosu?

gosu help ruby linux problem gosu/ruby reply

This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 RedFox

RedFox

    CC Lurker

  • Just Joined
  • Pip
  • 2 posts

Posted 27 November 2014 - 12:27 PM

Hello! I am having a problem to install gosu to compile my project in ruby I tried installing with the command:
-------------------------------------------------- ---------------------------------
gem install gosu
-------------------------------------------------- ---------------------------------
more of an error:
-------------------------------------------------- ---------------------------------
peterpan @ Egypt: ~ / Desktop $ gem install gosu
ERROR: While executing gem ... (Gem :: FilePermissionError)
     You do not have write permissions into the /var/lib/gems/1.9.1 directory.
peterpan @ Egypt: ~ / Desktop $

-------------------------------------------------- ---------------------------------
cuando I compile the project:
-------------------------------------------------- ---------------------------------
peterpan @ Egypt: ~ / Desktop $ ruby tiled.rb
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require ': can not load such file - gosu (LoadError)
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require '
from tiled.rb: 9: in `<main> '
peterpan @ Egypt: ~ / Desktop $

-------------------------------------------------- ----------------------------------
help me please !!!



#2 BlackRabbit

BlackRabbit

    CodeCall Legend

  • Expert Member
  • PipPipPipPipPipPipPipPip
  • 3871 posts

Posted 27 November 2014 - 05:54 PM

Welcome aboard!

 

You are probably missing the Ruby Framework, check this link for the solution.



#3 RedFox

RedFox

    CC Lurker

  • Just Joined
  • Pip
  • 2 posts

Posted 28 November 2014 - 11:00 AM

hm..! do not work! I have Ubuntu 14.04 LTS not MacOSX

 

...

 

help-my please!!



#4 BlackRabbit

BlackRabbit

    CodeCall Legend

  • Expert Member
  • PipPipPipPipPipPipPipPip
  • 3871 posts

Posted 30 November 2014 - 02:05 PM

Your answer is on the rubyBuntu common problems

The problem seems to be about the LOAD_PATH being disabled by default due to some security risk.






Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download