Jump to content


Check out our Community Blogs

Register and join over 40,000 other developers!


Recent Status Updates

View All Updates

Photo
- - - - -

Allegro Error (Lnk1104)

allegro error LNK1104 Visual C++

  • Please log in to reply
14 replies to this topic

#13 kernelcoder

kernelcoder

    CC Devotee

  • Expert Member
  • PipPipPipPipPipPip
  • 990 posts
  • Location:Dhaka
  • Programming Language:C, Java, C++, C#, Visual Basic .NET
  • Learning:Objective-C, PHP, Python, Delphi/Object Pascal

Posted 29 April 2012 - 05:19 AM

Did you use double black slash for path or single, remember you need to use double slash. As example, if your hello.png is in the Images Directory at D drive, the should write like following...
image = al_load_bitmap("D:\\Images\\hello.png");

Did you try like that?
  • 0

#14 robbiewoods05

robbiewoods05

    CC Regular

  • Member
  • PipPipPip
  • 40 posts
  • Learning:C++, C#, Haskell

Posted 29 April 2012 - 05:25 AM

Yeah I was using double slashes so it didn't register as an escape sequence

Got it. It seems allegro wanted an absolute path with forward slashes rather than backward. Sorry for being a noob guys.
  • 0

#15 kernelcoder

kernelcoder

    CC Devotee

  • Expert Member
  • PipPipPipPipPipPip
  • 990 posts
  • Location:Dhaka
  • Programming Language:C, Java, C++, C#, Visual Basic .NET
  • Learning:Objective-C, PHP, Python, Delphi/Object Pascal

Posted 20 May 2012 - 07:18 PM

Did you use forward slash or backward slash in absolute path? It seems Allegro expects forward slash (/) in loading resources. The tutorial is here -- http://wiki.allegro....g)#Fix_the_Path
  • 0





Also tagged with one or more of these keywords: allegro, error, LNK1104, Visual C++

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download