Jump to content


Check out our Community Blogs

Register and join over 40,000 other developers!


Recent Status Updates

View All Updates

Photo
- - - - -

And again...

encryption hardware

  • Please log in to reply
11 replies to this topic

#1 Fae

Fae

    CC Resident

  • Advanced Member
  • PipPipPipPip
  • 77 posts

Posted 22 December 2010 - 04:00 PM

I hope to goodness this is the last one.

Sorry to bother you all again, but having more problems with this stupid thing. I managed to get the wireless connected a total of once, and I haven't looked at Linux since. Probably because it just gives me a massive headache every time I try - it's easier to just do my stuff in Windows.

Well, I fancied an explore into PGP the other day, and decided to try it out on Linux. I thought it would be easier what with the package managers and whatnot. Once again, my wireless simply won't connect. I tried the ifconfig wlan0 up command again, and nothing.

What happens is this: It does the spin-around animation on the icon for a while, and then asks me for the PSK. I check that the key is correct and confirm it, and then the icon does its spinny animation before it asks me for the key again etc etc...

So once again I'm relocating between houses to use the wired connection (as my router at home seems to be bust - the LAN ports at the back can't seem to make and sustain a connection, which is very irritating as it's only 2 years old) in order to search the net for anything that might help.

I've looked on this Debian wiki page and followed all of the instructions; same result. I've searched for people having the same problem across the net, but haven't turned up anything that's similar. I find it odd on that debian wiki page that it tells you explicitly not to add your essid and PSK to the /etc/network/interfaces file, and then later it tells you how to add that same data to the file. I've used chmod as it said to restrict access to root only, but still, it doesn't seem secure...

I've left the reference to wlan0 in there, but taken the ESSID and PSK out.

Either way, it didn't work again. I'm using GNOME desktop, and have network manager and wpa supplicant installed, there's no wpa supplicant configuration file in the /etc/wpa_supplicant/ directory, either (and some pages I looked at made reference to this)

As I said before, I have two wireless routers that I use to connect; my home one is Knet, and the other one is Lnet. Lnet is the router whose LAN ports work okay, so this is the one I'm testing myconnection on when I'm searching for how to configure it properly, however, even after several connection attempts here, the ESSID still lists Knet as its connection. Dunno if this is relevant, but it's something I've noticed.

So, here's some copies and pastes of some data that I hope is relevant; I hope this is enough information, just ask if you need anytihng else.

iwconfig:

root@Nebula-III:/home/fae# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     802.11bg  ESSID:"Knet"  Nickname:"rtl8192E"
          Mode:Ad-Hoc  Frequency=2.457 GHz  Cell: CA:FA:8C:88:EB:4A   
          Bit Rate=1 Mb/s   
          Retry:on   RTS thr:off   Fragment thr:off
          Encryption key: (I'm reluctant to leave this here ;) )   Security mode:open
          Power Management:off
          Link Quality=93/100  Signal level=-51 dBm  Noise level=-116 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

pan0      no wireless extensions.

ifconfig:

root@Nebula-III:/home/fae# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:24:54:5b:bb:bc  
          inet addr:192.168.0.4  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::224:54ff:fe5b:bbbc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:59412 errors:0 dropped:0 overruns:0 frame:0
          TX packets:54643 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:63062155 (60.1 MiB)  TX bytes:10307459 (9.8 MiB)
          Interrupt:19 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:117 errors:0 dropped:0 overruns:0 frame:0
          TX packets:117 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:9324 (9.1 KiB)  TX bytes:9324 (9.1 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:e0:4c:00:00:01  
          inet addr:10.42.43.1  Bcast:10.42.43.255  Mask:255.255.255.0
          inet6 addr: fe80::2e0:4cff:fe00:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:153 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:37731 (36.8 KiB)
          Interrupt:16 Memory:ffffc900050d0000-ffffc900050d0100

Thanks in advance for any help... Sorry for being such a pest v_v

And failing this, I think I may jusy give up on Debian entirely. I was thinking of trying Mandriva... It's based on Red Hat, I hear, and being as Red Hat is a very commercial distribution of Linux, it might improve my chances of getting better employment. What do you guys think?
  • 0
I'll ask a lot of questions (most of them probably stupid stuff). Bear with me, i'm still learning! ^_^ Also, I'll try to answer as many questions as I can as well, but I'm not very good yet. I'm sure I'll be of more use once I get better :)

#2 mr mike

mr mike

    CC Resident

  • Just Joined
  • PipPipPipPip
  • 89 posts

Posted 22 December 2010 - 04:26 PM

Hello
What is your wireless card?

If you want to try a different distro, check out either Fedora(RedHat uses yum, my favorite flavor), Simply Mepis(all wireless works out of the box? 95% of the time), or
my least favorite but easiest all around, Ubuntu(debian).
  • 0

#3 Alexander

Alexander

    YOL9

  • Moderator
  • 3963 posts
  • Location:Vancouver, Eh! Cleverness: 200
  • Programming Language:C, C++, PHP, Assembly

Posted 22 December 2010 - 05:00 PM

I've no access to a box with wireless controls so this is off memory, your wpa_supplicant conf is most likely located under /etc/wpa_supplicant.conf and must contain the following skeleton:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

eapol_version=1
ap_scan=1 #broadcast
fast_reauth=1

network={
    ssid="[B]<your ssid ascii>[/B]"
    proto=RSN #RSN is WPA2
    key_mgmt=WPA-PSK
    pairwise=CCMP TKIP
    group=CCMP TKIP
    psk="[B]<your PSK generated key in hexadecimal, not ascii>[/B]"
}
Your PSK was most likely generated from the command from your guide "wpa_passphrase <your ssid> <your ascii password>" of course replacing with what you chose.

Your /etc/networking/interfaces file should contain basic information about your wireless interface, it hopefully is there, an example is like so:
iface wlan0 inet static
address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.254
You may wish to utilize DHCP instead of static IP by replacing the whole files contents with this:
auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant.conf
You can restart network interfaces by
/etc/init.d/networking restart
And it should connect with your WPA2-PSK AP.

Maybe try giving that a go and see how it works, there are all too many configuration setups for different chips or systems, hope that works!
  • 0

All new problems require investigation, and so if errors are problems, try to learn as much as you can and report back.


#4 Fae

Fae

    CC Resident

  • Advanced Member
  • PipPipPipPip
  • 77 posts

Posted 23 December 2010 - 10:23 AM

Thanks again for the help, all.

@Mr. Mike
My card is a Realtek RTL8192E model; sorry, I forgot to repost that info in this thread ^^
Why don't you like Ubuntu? Everyone else I've talked to speaks very highly of it.

@Nullw0rm
Thanks for this; there's no wpa_supplicant.conf file in /etc/, I'll make one now. The only one I found after searching for my computer is in /etc/dbus-1/system.d/, and contains the following:

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
        <policy user="root">
                <allow own="fi.epitest.hostap.WPASupplicant"/>

                <allow send_destination="fi.epitest.hostap.WPASupplicant"/>
                <allow send_interface="fi.epitest.hostap.WPASupplicant"/>
        </policy>
        <policy group="netdev">
                <allow send_destination="fi.epitest.hostap.WPASupplicant"/>
                <allow send_interface="fi.epitest.hostap.WPASupplicant"/>
        </policy>
        <policy context="default">
                <deny own="fi.epitest.hostap.WPASupplicant"/>
                <deny send_destination="fi.epitest.hostap.WPASupplicant"/>
                <deny send_interface="fi.epitest.hostap.WPASupplicant"/>
        </policy>
</busconfig>

I had this in my interfaces file already; I added it myself last night:

auto wlan0
iface wlan0 inet dhcp

...but I did not realise you needed a link to a configuration file. My routers both use DHCP, but I was wondering for future reference; the address in the static IP configuration is the intended IP of the local device, right? And also, does Gateway refer to the local IP of the router, or the Gateway IP Address as stated on the router's status page?

Okay, I've just tried it, and got this:

root@Nebula-III:/home/fae# /etc/init.d/networking restart
Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces ... (warning).
Reconfiguring network interfaces...Internet Systems Consortium DHCP Client 4.1.1-P1
Copyright 2004-2010 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/00:e0:4c:00:00:01
Sending on   LPF/wlan0/00:e0:4c:00:00:01
Sending on   Socket/fallback
Internet Systems Consortium DHCP Client 4.1.1-P1
Copyright 2004-2010 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/00:24:54:5b:bb:bc
Sending on   LPF/eth0/00:24:54:5b:bb:bc
Sending on   Socket/fallback
DHCPRELEASE on eth0 to 192.168.0.1 port 67
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Internet Systems Consortium DHCP Client 4.1.1-P1
Copyright 2004-2010 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/00:e0:4c:00:00:01
Sending on   LPF/wlan0/00:e0:4c:00:00:01
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
done.

...so, is this a problem with wpa_supplicant? I'm not exactly sure what's going on here, but at a guess I'd say that because wpa_supplicant isn't starting, it can't convey the keyover using the proper encryption, and therefore the router's DHCP won't assign me an IP.

Am I in the right general area?

Also, being as I have two routers to connect to and the conf file contains a reference to one of them; so, can I make a directory called wpa_supplicant.conf.d to hold multiple files of this nature? I've noticed some other things do it like this in Linux, so surely I'd need a new conf file for each?

Thanks again :)
  • 0
I'll ask a lot of questions (most of them probably stupid stuff). Bear with me, i'm still learning! ^_^ Also, I'll try to answer as many questions as I can as well, but I'm not very good yet. I'm sure I'll be of more use once I get better :)

#5 mr mike

mr mike

    CC Resident

  • Just Joined
  • PipPipPipPip
  • 89 posts

Posted 23 December 2010 - 11:50 AM

Sorry I was blind, saw your wireless in the code block today.
You can try this(My lazy attempt to help):
1. Download the Driver.
2. Follow this guide.

I really don't think Ubuntu is bad, its just not my ideal distro, its bloated and overloaded with apps I dont use. On the other hand people might say Fedora is bloated too, but it uses SELinux(though not perfect) for a hardened system out of the box and I like yum.

Ideally I really prefer Gentoo or lfs(Only what you need or want), but I dont have the time to get the system working 100%, plus you get to know your system better.
  • 0

#6 Alexander

Alexander

    YOL9

  • Moderator
  • 3963 posts
  • Location:Vancouver, Eh! Cleverness: 200
  • Programming Language:C, C++, PHP, Assembly

Posted 23 December 2010 - 03:45 PM

Hi, I believe most of what you said was true (I just woke up), the static IP should be the current computer and gateway the router or hub currently used, DHCP from the gateway can automatically handle all that so static IP is not required.

Try running the following command:
wpa_supplicant -Bw -iwlan0 -c/etc/wpa_supplicant.conf -dd

This will start the wpa supplicant in verbose debugging mode so we can see why it returned 1 (an error), if this can work then we can add it to our /etc/networking/interfaces file to automatically pass those parameters each startup. Hope this helps!
  • 0

All new problems require investigation, and so if errors are problems, try to learn as much as you can and report back.


#7 Fae

Fae

    CC Resident

  • Advanced Member
  • PipPipPipPip
  • 77 posts

Posted 24 December 2010 - 03:39 AM

Hi, NullW0rm,

Thanks for posting tech support on christmas Eve, I really appreciate it! ^_^

I'm a bit pressed for time here due to family, so I'll just post the output. I'm not gonna change my key output either.

root@Nebula-III:/home/fae# wpa_supplicant -Bw -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -dd
wpa_supplicant: invalid option -- 'w'
wpa_supplicant v0.6.10
Copyright (c) 2003-2009, Jouni Malinen <j@w1.fi> and contributors

This program is free software. You can distribute it and/or modify it
under the terms of the GNU General Public License version 2.

Alternatively, this software may be distributed under the terms of the
BSD license. See README and COPYING for more details.

This product includes software developed by the OpenSSL Project
for use in the OpenSSL Toolkit (http://www.openssl.org/)

usage:
  wpa_supplicant [-BddhKLqqstuvW] [-P<pid file>] [-g<global ctrl>] \
        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] [-p<driver_param>] \
        [-b<br_ifname>] [-f<debug file>] \
        [-N -i<ifname> -c<conf> [-C<ctrl>] [-D<driver>] \
        [-p<driver_param>] [-b<br_ifname>] ...]

drivers:
  wext = Linux wireless extensions (generic)
  nl80211 = Linux nl80211/cfg80211
  wired = wpa_supplicant wired Ethernet driver
options:
  -b = optional bridge interface name
  -B = run daemon in the background
  -c = Configuration file
  -C = ctrl_interface parameter (only used if -c is not)
  -i = interface name
  -d = increase debugging verbosity (-dd even more)
  -D = driver name
  -f = log output to debug file instead of stdout
  -g = global ctrl_interface
  -s = log output to syslog instead of stdout
  -K = include keys (passwords, etc.) in debug output
  -t = include timestamp in debug messages
  -h = show this help text
  -L = show license (GPL and BSD)
  -p = driver parameters
  -P = PID file
  -q = decrease debugging verbosity (-qq even less)
  -u = enable DBus control interface
  -v = show version
  -W = wait for a control interface monitor before starting
  -N = start describing new interface
example:
  wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf

it said that the --w was an invalid switch, so I assumed this was the -Bw switch; I did it with just -B, and got this

root@Nebula-III:/home/fae# wpa_supplicant -B -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -dd
Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group='0'
eapol_version=1
ap_scan=1
fast_reauth=1
Line: 8 - start of a new network block
ssid - hexdump_ascii(len=4):
     4c 6e 65 74                                       Lnet            
proto: 0x2
key_mgmt: 0x2
pairwise: 0x18
group: 0x18
Line 14: Invalid passphrase length 64 (expected: 8..63) '8c7ebbb8ed6434515d9b4dd808e12bcc5a9cac3db9eafba620a1b4bc0c30bcf3"'.
Line 14: failed to parse psk '"8c7ebbb8ed6434515d9b4dd808e12bcc5a9cac3db9eafba620a1b4bc0c30bcf3"'.
Line 15: WPA-PSK accepted for key management, but no PSK configured.
Line 15: failed to parse network block.
Failed to read or parse configuration '/etc/wpa_supplicant/wpa_supplicant.conf'.
Failed to add interface wlan0
Cancelling scan request
Cancelling authentication timeout

Hope this is okay, thanks again for your help!
  • 0
I'll ask a lot of questions (most of them probably stupid stuff). Bear with me, i'm still learning! ^_^ Also, I'll try to answer as many questions as I can as well, but I'm not very good yet. I'm sure I'll be of more use once I get better :)

#8 Alexander

Alexander

    YOL9

  • Moderator
  • 3963 posts
  • Location:Vancouver, Eh! Cleverness: 200
  • Programming Language:C, C++, PHP, Assembly

Posted 24 December 2010 - 01:42 PM

Hi Fae, it appears you are using an alternate version of wpa_supplicant, maybe try this

Try to change your /etc/network/interfaces line to this with ascii password
auto wlan0
iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    wpa-ssid Knet
    wpa-psk ascii-passphrase-here
Try to change your PSK in /etc/wpa_supplicant/wpa_supplicant.conf to your plaintext ascii password instead of hash
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

eapol_version=1
ap_scan=1 
fast_reauth=1

network={
    ssid="Knet"
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP TKIP
    group=CCMP TKIP
    psk = ascii-passphrase-here
}
From your earlier ifconfig output it appears your card is in Ad-hoc mode too, maybe try this:
[I]iwconfig[/I] wlan0 [I]mode managed[/I]
wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -dd
That may work, hope that helps and merry Christmas!
  • 0

All new problems require investigation, and so if errors are problems, try to learn as much as you can and report back.


#9 Fae

Fae

    CC Resident

  • Advanced Member
  • PipPipPipPip
  • 77 posts

Posted 06 January 2011 - 03:06 PM

Hi Nullworm / Alexander, hope you had a wonderful Christmas / other holiday, and New Year! ^^

I'm in a position again to connect via wire, so I thought I'd give this another go. Although I'm connecting from Lnet right now, this is the details from Knet, which I tried briefly before.

Okay, so I tried your thing, and got this:

root@Nebula-III:/home/fae# wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -dd
Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group='wheel'
eapol_version=1
ap_scan=1
fast_reauth=1
Line: 8 - start of a new network block
ssid - hexdump_ascii(len=4):
     4b 6e 65 74                                       Knet            
proto: 0x2
key_mgmt: 0x2
pairwise: 0x18
group: 0x18
PSK (ASCII passphrase) - hexdump_ascii(len=10): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Priority group 0
   id=0 ssid='Knet'
Initializing interface (2) 'wlan0'
Interface wlan0 set UP - waiting a second for the driver to complete initialization
SIOCGIWRANGE: WE(compiled)=22 WE(source)=18 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf flags 0x0
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWESSID]: Operation not permitted
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:e0:4c:00:00:01
wpa_driver_wext_set_wpa
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
wpa_driver_wext_set_drop_unencrypted
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
WPS: UUID based on MAC address - hexdump(len=16): 18 da ee 30 5d 42 51 84 82 01 42 0f d6 56 33 57
WPS: Build Beacon and Probe Response IEs
WPS:  * Version
WPS:  * Wi-Fi Protected Setup State (0)
WPS:  * Version
WPS:  * Wi-Fi Protected Setup State (0)
WPS:  * Response Type (2)
WPS:  * UUID-E
WPS:  * Manufacturer
WPS:  * Model Name
WPS:  * Model Number
WPS:  * Serial Number
WPS:  * Primary Device Type
WPS:  * Device Name
WPS:  * Config Methods (0)
WPS:  * RF Bands (3)
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
Using existing control interface directory.
CTRL: Invalid group 'wheel'
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

Failed to add interface wlan0
No keys have been configured - skip key clearing
State: DISCONNECTED -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_wext_set_wpa
wpa_driver_wext_set_drop_unencrypted
wpa_driver_wext_set_countermeasures
No keys have been configured - skip key clearing
Cancelling scan request
Cancelling authentication timeout
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWESSID]: Operation not permitted
WEXT: Operstate: linkmode=0, operstate=6

...In your last post, you had ctrl_interface_group=wheel in your wpa_supplicant.conf thing, so I changed it to this, but it gave me the above error message saying it didn't know what 'wheel' was, so I changed it back to 0, and got this:

root@Nebula-III:/home/fae# ifconfig wlan0 mode managed
mode: Unknown host
ifconfig: `--help' gives usage information.
root@Nebula-III:/home/fae# iwconfig wlan0 mode managed
root@Nebula-III:/home/fae# wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -dd
Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
Initializing interface (2) 'wlan0'
SIOCGIWRANGE: WE(compiled)=22 WE(source)=18 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf flags 0x0
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWESSID]: Operation not permitted
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:e0:4c:00:00:01
wpa_driver_wext_set_wpa
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
wpa_driver_wext_set_drop_unencrypted
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
WPS: UUID based on MAC address - hexdump(len=16): 18 da ee 30 5d 42 51 84 82 01 42 0f d6 56 33 57
WPS: Build Beacon and Probe Response IEs
WPS:  * Version
WPS:  * Wi-Fi Protected Setup State (0)
WPS:  * Version
WPS:  * Wi-Fi Protected Setup State (0)
WPS:  * Response Type (2)
WPS:  * UUID-E
WPS:  * Manufacturer
WPS:  * Model Name
WPS:  * Model Number
WPS:  * Serial Number
WPS:  * Primary Device Type
WPS:  * Device Name
WPS:  * Config Methods (0)
WPS:  * RF Bands (3)
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
Added interface wlan0
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Trying to get current scan results first without requesting a new scan to speed up initial association
Received 1182 bytes of scan results (4 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
Setting scan request: 0 sec 0 usec
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 5 seconds
EAPOL: disable timer tick
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 1187 bytes of scan results (4 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: SCANNING -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 895 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 895 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 895 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 896 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 893 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 896 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 894 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 894 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 895 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 895 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
^CCTRL-EVENT-TERMINATING - signal 2 received
Removing interface wlan0
No keys have been configured - skip key clearing
State: INACTIVE -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_wext_set_wpa
wpa_driver_wext_set_drop_unencrypted
wpa_driver_wext_set_countermeasures
No keys have been configured - skip key clearing
Cancelling scan request
Cancelling authentication timeout
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWESSID]: Operation not permitted
WEXT: Operstate: linkmode=0, operstate=6

I stopped it as it appeared to be looping. Above was in managed mode, like you said, but I tried it in ad-hoc mode too:

root@Nebula-III:/home/fae# iwconfig wlan0 mode ad-hoc
root@Nebula-III:/home/fae# wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -dd
Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
Initializing interface (2) 'wlan0'
SIOCGIWRANGE: WE(compiled)=22 WE(source)=18 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf flags 0x0
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWESSID]: Operation not permitted
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:e0:4c:00:00:01
wpa_driver_wext_set_wpa
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
wpa_driver_wext_set_drop_unencrypted
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
WPS: UUID based on MAC address - hexdump(len=16): 18 da ee 30 5d 42 51 84 82 01 42 0f d6 56 33 57
WPS: Build Beacon and Probe Response IEs
WPS:  * Version
WPS:  * Wi-Fi Protected Setup State (0)
WPS:  * Version
WPS:  * Wi-Fi Protected Setup State (0)
WPS:  * Response Type (2)
WPS:  * UUID-E
WPS:  * Manufacturer
WPS:  * Model Name
WPS:  * Model Number
WPS:  * Serial Number
WPS:  * Primary Device Type
WPS:  * Device Name
WPS:  * Config Methods (0)
WPS:  * RF Bands (3)
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
Added interface wlan0
RTM_NEWLINK: operstate=0 ifi_flags=0x1043 ([UP][RUNNING])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b15 len=24
Wireless event: new AP: 00:00:00:00:00:00
Added BSSID 00:00:00:00:00:00 into blacklist
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
State: DISCONNECTED -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
RTM_NEWLINK: operstate=0 ifi_flags=0x1043 ([UP][RUNNING])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Trying to get current scan results first without requesting a new scan to speed up initial association
Received 898 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No APs found - clear blacklist and try again
Removed BSSID 00:00:00:00:00:00 from blacklist (clear)
No suitable AP found.
Setting scan request: 0 sec 0 usec
EAPOL: disable timer tick
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 5 seconds
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 897 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: SCANNING -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 897 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=16
Received 894 bytes of scan results (3 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
No suitable AP found.
State: INACTIVE -> INACTIVE
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=16
^CCTRL-EVENT-TERMINATING - signal 2 received
Removing interface wlan0
No keys have been configured - skip key clearing
State: INACTIVE -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_wext_set_wpa
wpa_driver_wext_set_drop_unencrypted
wpa_driver_wext_set_countermeasures
No keys have been configured - skip key clearing
Cancelling scan request
Cancelling authentication timeout
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWESSID]: Operation not permitted
WEXT: Operstate: linkmode=0, operstate=6

Seems to be doing the same sort of thing.

I don't have much understanding of the different types of wireless networks; ad-hoc is similar to peer-to-peer connections, with each device providing an access point to the network, and managed is more client-server style insomuch as you need to connect to the main access point (in my case, the router), am I right?

Also, I'm not really comfortable leaving my unencrypted key in a file on my computer in its ASCII format... Would locking it so only Root can read/write the file be okay, or is there something more I can do to protect my keys from snoopy people?

Final question: I'm using WPA2-PSK encryption on my keys, but my files only say WPA-PSK. Is this relevant, or are the keys encrypted and passed along in the same way for both?

Thank you again, and sorry for being such a pest :)

~Fae
  • 0
I'll ask a lot of questions (most of them probably stupid stuff). Bear with me, i'm still learning! ^_^ Also, I'll try to answer as many questions as I can as well, but I'm not very good yet. I'm sure I'll be of more use once I get better :)

#10 Alexander

Alexander

    YOL9

  • Moderator
  • 3963 posts
  • Location:Vancouver, Eh! Cleverness: 200
  • Programming Language:C, C++, PHP, Assembly

Posted 06 January 2011 - 04:58 PM

Yes I changed my name, it feels better. :) I am afraid Fae I am only knowledgeable in setting up WPA on non-debian distributions, and it was quite a while ago. There are some things that are completely different and I am not sure.

Feel free to try on the Ubuntu forums (should be the same) or Debian forums/mail lists if those are active, and be sure to link to this thread so they can gain more context and information.

I hope the best, I know it feels so great to get things working after literally days of messing with faulty configurations. I wish you luck!
  • 0

All new problems require investigation, and so if errors are problems, try to learn as much as you can and report back.


#11 Fae

Fae

    CC Resident

  • Advanced Member
  • PipPipPipPip
  • 77 posts

Posted 07 January 2011 - 02:39 AM

hehe, well thank you very much for trying to help anyways, I really do appreciate it. Plus, I learned a lot from this, and that's the aim of the game really! ^^

I'll post a resolution up here once I find one, just to tie up the loose ends.

Thanks again for your help and patience! :)

~Fae
  • 0
I'll ask a lot of questions (most of them probably stupid stuff). Bear with me, i'm still learning! ^_^ Also, I'll try to answer as many questions as I can as well, but I'm not very good yet. I'm sure I'll be of more use once I get better :)

#12 AxleCage

AxleCage

    CC Newcomer

  • Just Joined
  • PipPip
  • 13 posts

Posted 10 January 2011 - 06:14 PM

What network manager are you using with wireless? When trying to get my network up and running I kept getting an error with my passkey though I checked and checked again and it was correct.

My solution that worked for me to finally get into my network was I had to remove network-manager, reinstall wpa-supplicant and then install the wicd wireless manager. I read somewhere(though I do not remember where) that networkmanager has problems with passkeys for wpa1/2.

So if you are using networkmanager instead of wicd that may be the problem.
  • 0





Also tagged with one or more of these keywords: encryption, hardware

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download