Jump to content


Check out our Community Blogs

Register and join over 40,000 other developers!


Recent Status Updates

View All Updates

Photo
- - - - -

login screen using asp.net configuration in vb 2008

asp.net login

  • Please log in to reply
2 replies to this topic

#1 clopo87

clopo87

    CC Lurker

  • Just Joined
  • Pip
  • 2 posts

Posted 23 October 2009 - 06:26 PM

Hello i am attempting to create a login for my website in vb 2008 using the asp.net configuration. However when i click on the security tab i get the following error:

'There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.

The following message may help in diagnosing the problem: Unable to connect to SQL Server database.'

does anybody know what this means? i have googled it but everything i try doesnt work.

thank-you
Chloe
  • 0

#2 so1i

so1i

    CC Addict

  • Advanced Member
  • PipPipPipPipPip
  • 297 posts

Posted 23 October 2009 - 11:56 PM

Seems to me to mean what it's telling you, your logging in as someone without permission to access the security, or your user/pass isn't right. Are you sure you are using the correct login information (for connection to the dBase)?

Not sure about the 'role manager' bit. Maybe in your SQL Server settings you can alter this? But as it's 'unable to connect to the SQL Server' I suspect it's the actual connection to that, rather than the details you are using to login to the website. In the asp.net connection string, verify you have the correct path/user/password to your SQL Server :)
  • 0

#3 clopo87

clopo87

    CC Lurker

  • Just Joined
  • Pip
  • 2 posts

Posted 24 October 2009 - 04:45 PM

hello,

thanks for your reply. yes ive already checked my user/password settings for connecting to the database. they are right and it says test succeeded when i test it in visual studio. so i dont know why it is saying that.
ive tried to access the security settings on SQL Server Enterprise Manager but it says to open up Microsoft SQL Servers group to change it but my computer does not have this option, as shown in the steps below.....

'How to launch SQL Server Enterprise Manager in the Computer Management console

Note In Microsoft® Windows® 2000, you can access SQL Server Enterprise Manager from the Computer Management console.

To launch SQL Server Enterprise Manager in the Computer Management console

1. On the Start menu, point to Programs, point to Administrative Tools, and then click Computer Management.

2. Expand the Services and Applications group.

3. Expand the Microsoft SQL Servers group.'

So im still trying to figure it out.
  • 0





Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download