Jump to content







- - - - -

How to: Steam on Linux (Debian 7.0)

  Posted by Yannbane, 16 February 2013 · 1,790 views

Today I've successfully, and without much trouble, installed Linux on my Debian Wheezy PC.

This goes without saying, but honestly, I never thought I'd see the day. Running Half Life nice and smooth... On Linux. Wow.

Although there were really no actual problems with the installation process, there were some annoyances, so I've decided to compile a short list of steps that you should follow in order to use Steam on Debian. Please note that these only solve problems which I myself have encountered, and that they are usually solved for you if you use Ubuntu.

The list is quite short, but I'll keep adding more items to it. Make sure you read through all of them though, because they might not be in the order of occurrence!

  1. Download: steam_latest.deb
  2. Installation

    After you have downloaded "steam_latest.deb" into your ~/Downloads directory or wherever, open up a terminal, execute cd ~/Downloads and then just invoke the Debian package manager in order to install it: sudo dpkg -i steam_latest.deb.

  3. Missing dependencies

    The installation will probably fail, and complain about missing dependencies.
    In order to fix issues like this one, not just with Steam but with any package you're installing manually, run sudo apt-get -f install.

  4. Wrong architecture

    It's quite possible that you're running a x64 (64 bit) system, like I am. The current Steam Debian package only supports the x86 (32 bit), and you will have to enable i386 (fancy Intel name for 32 bit) packages. Don't worry, Linux handles both architectures flawlessly, and your 64 bit programs keep using 64 bit libraries.

    To add the i386 arch execute: sudo dpkg --add-architecture i386 && sudo apt-get update and wait for it to finish. You should now be able to install Steam.

  5. Missing GLIBC_2.5

    This is quite an annoying one, that I encountered just after the installation.

    1. cd
    2. mkdir steamlibs
    3. nano .bashrc
      Add the following lines:

      STEAMLIBS=${HOME}/steamlib
      LD_LIBRARY_PATH=${STEAMLIBS}

      export STEAMLIBS
      export LD_LIBRARY_PATH
    4. wget http://security.ubun...tu10.2_i386.deb
    5. dpkg -x libc6_2.15-0ubuntu10.2_i386.deb /tmp/libc/
    6. mv /tmp/libc/lib/i386-linux-gnu/* ${STEAMLIBS}

  6. No sound in game

    When I first started Half Life, it was muted. I'm using ALSA as the sound server, however, so this fix will not work for PulseAudio users (who shouldn't have the problem in the first place).

    1. Quit Steam.
    2. Execute sudo nano /usr/bin/steam.
    3. Get to the bottom of the page, and add export SDL_AUDIODRIVER=alsa before the last comment (line starting with a '#').
    4. Run Steam again and your games should have audio.

F.A.Q.

  1. Q: does Steam run background processes even after I quit it? A: No! If you want to check, do this: ps -e | grep steam.


<a href="http://www.yannbane....-debian-70.html">Source</a>

  • 0



Within "Wrong architecture," after --add-architecture, you need to modify your sources.list as well. (Unless debian has automated this and i haven't paid attention..)

vi /etc/apt/sources.list

change occurences of 

 

deb http:/..

to 

 

deb [arch=amd64,i386] http:/..
    • 0

Within "Wrong architecture," after --add-architecture, you need to modify your sources.list as well. (Unless debian has automated this and i haven't paid attention..)
vi /etc/apt/sources.list
change occurences of 

deb http:/..
to 
 
deb [arch=amd64,i386] http:/..


You don't have to do that...
    • 0

Trackbacks for this entry [ Trackback URL ]

There are no Trackbacks for this entry

April 2014

S M T W T F S
  12345
6789101112
131415161718 19
20212223242526
27282930   

Recent Entries

Recent Comments

My Picture

0 user(s) viewing

0 members, 0 guests, 0 anonymous users

Tags

Categories